WordPressで、「アドセンスの広告ユニットが表示されなくなった」について

WordPressで、「アドセンスの広告ユニットが表示されなくなった」について

7月23日から24日にかけて、Wordpressのアップデートがあり、Ver4.2.3になってからの様な気がします。

しかも、このWordPressのアップデートは、以前のバージョンから、自動でアップデートが実行されるように、便利に? なったのは良いのですが、何か不具合を起こした時には、始末が悪いのです。

WordPress(Ver4.2.3)のアップデートのせいか? 確定はしていませんが、アドセンスのコードを何もいじっていないにもかかわらず、記事中に入れた広告が表示されなくなるか、スマホなどで確認すると、小さく広告下の他の部分に被って表示される様な状態になっています。

Sponsored Links





1.現象

1)皆さん、記事を書く時は、通常、モードを「ビジュアル」にして、記載すると思います。

2)アドセンスのコードを貼り付ける時は、モードを「テキスト」にして、貼り付けるでしょう。

3)その後、モードを「ビジュアル」にして、記事を「更新」すると思います。

一度、ところが、「ビジュアル」で表示後、「テキスト」表示に戻すと、アドセンスのコードは上記の様に、配置がずれてしまいます。

今までは、この状態でも、アドセンスの広告は、ちゃんと表示されていたと思います。

今回のWordpressのアップデートで、どうやらこれがダメなようです。

ですので、「ビジュアル」表示で記事を記載後、「テキスト」表示にして、アドセンスの広告を埋め込んだ後、「ビジュアル」表示に戻さないで、「テキスト」表示のまま、「更新」を書けると、コードが崩れず、広告がちゃんと表示されるようになります。

どうやら、「テキストエディター」の仕様が、大きく変更になったのでしょうか?

2.対策

今の所、対策するとしたら、3つくらい有ると思いますが、Wordpressの次回アップデートで直るのか?どうかにもよりますので。。。。何とも言えませんが、とにかく、「広告」表示されるようにしないと、大変ですので。。。。

1)既存の記事は、アドセンスのページよりコードをCOPYして、貼りなおして、「テキスト」表示のまま、「更新」をかける。

既存の記事は、広告コードを「テキスト」表示にして、アドセンスのページよりCOPYして、貼りなおして、「テキスト」表示のまま、「更新」をかける。

新記事の場合、「ビジュアル」表示で記事を記載後、「テキスト」表示にして、アドセンスの広告を埋め込んだ後、「ビジュアル」表示に戻さないで、「テキスト」表示のまま、「更新」をかけると、コードが崩れず、広告がちゃんと表示されるようになります。

この方法を採用すると、「全記事」、テキストエディターを開いて、実施する必要が有ります。

2)Wordpressのバージョンを前に戻す。

この方法が、一番、手っ取り早い方法ですが。。。。。

但し、危険です!!

(1)今までの記事、Wordpressのバックアップを取る必要が有ります。

失敗した時の為に、書き戻す方法も学習する必要が有ります。

(2)Wordpressから以前のバージョンをタウンロードして、レンタルしているサーバーにログインして、サーバー内のWordpressのフォルダ内のファイルを入れ替える必要が有ります。

上書きをかけて良いファイルと、ダメなファイルも有ります。失敗した時は、バックアップが無いと、アウトです。

3)記事中に、直に、「広告コード」を埋め込まないで、別の方法で埋め込む。

私の場合も、サイドバーにいれた300×600の広告は、何も問題なく、表示されています。

要は、「テキスト」表示のまま保存できるテンプレートなどの「埋め込み方法」を採用出来れば、影響は受けない様ですので、その方法を採用する。

自動で埋め込む場合は、1ページに埋め込める広告は3つまでですので、今まで埋め込んだ記事中の広告を「表示されていなくても削除する必要があります」。。この方法を採用しても、全記事に埋め込んでいる場合、全部、修正する必要が出てきます。

大変ですが、今後、記事を書くタイミングで埋め込んでいた広告を貼り付ける必要が無くなります。

なれている方なら、この方法を採用している方は、けっこう、いらっしゃいます。

3.どの方法を採用して、広告を表示するか?

WordPressのバージョンを前に、戻す方法も考えましたが、余りにも危険ですし、セキュリティ上も最新バージョンの方が安心ですので、私の場合、取りあえず、2の1)の方法で、広告を貼りなおしています。

ただ、新記事を記載する時は、まあ、いいのですが、過去記事に「追記」する時などは、「ビジュアル」表示で記事に「追記」後、「テキスト」表示にして、アドセンスの広告を再度、貼りなおして、更新をかけないと表示されませんので、ちょっと面倒です。

7月28日、また、Wordpressのアップデートがあり、最新版に更新しましたが、ダメでした。

今後のアップデートで直るのかどうか?。。。。。これもまだ、分かりませんので、取りあえず、2の1)の方法で、広告を貼りなおしています。

皆さん、どう「対処」していますでしょうか?

追記> 2015年8月12日  「WordPress」の不具合

「WordPress」を 4.2.4にアップデートしたら、見事に直っていました。。。。。

どんな原因なのか? さっぱり、分からないので、ちょっと不安ですが、とにかく直っています。

もう一つ、記事中に、画像を埋め込む処理も、URLを指定しなくても、1発で挿入できるように、直っていました。

これも、対策方法も何もかも、分からず。。。。

WordPressも、結構、いい加減なとこもあるんだと、やっと認識できた次第で、勉強になりました。。。。としか言いようが有りません。

Sponsored Links





コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*